System requirements for running the xTIMEcomposer